Network Outage Affecting MDC Server in Tripoli

Incident Report for Libyan Spider

Update

We are continuing to investigate this issue.
Posted May 04, 2026 - 11:46 CEST

Investigating

We are currently investigating a network issue affecting all MDC servers in the Tripoli region. Users may experience connectivity issues or complete service unavailability for systems hosted in this region. Our engineering team is actively looking into the cause.
Posted May 04, 2026 - 11:09 CEST
This incident affects: Network (Tripoli) and Web Hosting Services (Tripoli Data Center).