Website and Client Area Performance Issues

Incident Report for Libyan Spider

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 16:48 CEST

Identified

We are currently investigating an issue affecting the Libyan Spider website and Client Area. Some users may experience slow loading times, intermittent errors, or difficulty accessing services.

Our technical team is actively working to identify the root cause and restore normal performance as soon as possible.

We will provide further updates as more information becomes available.
Posted Jun 19, 2026 - 16:17 CEST
This incident affected: Core Services (Clients Portal, LibyanSpider.com).