Internet Connectivity Degradation in Tripoli

Incident Report for Libyan Spider

Identified

Update: We have identified the cause of the network degradation and high latency in the Tripoli region. Our upstream service provider currently has scheduled maintenance in progress, which is impacting our network traffic.

We are in active communication with the provider to monitor their progress and will share further updates as we get more details on the estimated time to resolution. Thank you for your patience!
Posted Jul 23, 2026 - 18:24 CEST

Investigating

We are currently investigating a network degradation and high latency affecting services in the Tripoli region. Users may experience connectivity issues or partial service unavailability for systems hosted in this region. Our engineering team is actively looking into the cause.
Posted Jul 23, 2026 - 18:13 CEST
This incident affects: Network (Tripoli).