Service Disruption — Shared Server LS31

Incident Report for Libyan Spider

Resolved

This incident has been resolved.
Posted Jul 25, 2026 - 22:13 CEST

Identified

We are currently experiencing an issue affecting one of our shared servers (LS31). Websites, email, and other services hosted on this server may be unreachable.
Our team is actively working to resolve the issue and will provide updates as they become available.
Posted Jul 25, 2026 - 21:24 CEST
This incident affected: Web Hosting Services (Falkenstein Data Center).