Maintenance on Shared Windows server WS05

Incident Report for Libyan Spider

Resolved

The issue has been resolved, and the server is back online.
Posted May 06, 2026 - 18:48 CEST

Investigating

We have identified a critical issue requiring immediate maintenance on shared server WS05. Our team is currently working to resolve the issue.
Posted May 06, 2026 - 18:34 CEST
This incident affected: Web Hosting Services (Helsinki Data Center).